
  


<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="http://www.news-bulletin.com/content/tncms/live/" />
<meta name="keywords" content="meadow lake, double homicide, rudy romero, henry romero, jacob arnold, david mestas, samuel mestas, felicia anaya, valencia county sheriff's office, murder" />
<meta name="news_keywords" content="meadow lake, double homicide, rudy romero, henry romero, jacob arnold, david mestas, samuel mestas, felicia anaya, valencia county sheriff's office, murder" />
<meta name="description" content="Four Los Lunas residents have been arrested and are in custody tonight in connection with a double homicide in Meadow Lake." />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/e/84/e84959fa-740e-11eb-800e-5749e449e707/60320069a886e.preview.jpg?crop=823%2C437%2C11%2C54&amp;resize=823%2C437&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="823" />
<meta property="og:image:height" content="437" />
<meta property="og:title" content="Four suspects in custody for Meadow Lake double homicide" />
<meta property="og:description" content="Four Los Lunas residents have been arrested and are in custody tonight in connection with a double homicide in Meadow Lake." />
<meta property="og:site_name" content="Valencia County News-Bulletin" />
<meta property="og:section" content="News" />
<meta property="tncms:subs" content="2.0" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.8f9ea2aebd539706f1500a18510dd6e4.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/live/global/resources/styles/site.css?_dc=1452531918"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>/*<![CDATA[*/ #user-controls-1171979 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1171979 .tn-user-screenname, #user-controls-1171979 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1171979 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1171979 .dropdown-signup { font-size: 12px; } #user-controls-1171979 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1171979 .large-user-avatar { margin-right: 10px; } #user-controls-1171979 .large-user-controls { font-size: 12px; } #user-controls-1171979 .logout-btn { cursor: pointer; } #user-controls-1171979 .login-btn { color: #fff!important; } #user-controls-1171978 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1171978 .tn-user-screenname, #user-controls-1171978 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1171978 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1171978 .dropdown-signup { font-size: 12px; } #user-controls-1171978 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1171978 .large-user-avatar { margin-right: 10px; } #user-controls-1171978 .large-user-controls { font-size: 12px; } #user-controls-1171978 .logout-btn { cursor: pointer; } #user-controls-1171978 .login-btn { color: #fff!important; } .follow-links-1171966 li { margin-right: 1px; padding: 0; } .follow-links-1171966 li a, .follow-links-1171966 li a:focus, .follow-links-1171966 li a:active { ; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1171966 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1171966 li a.fb,.follow-links-1171966 li a.fb:hover { color: #3A59A5; } .follow-links-1171966 li a.tw,.follow-links-1171966 li a.tw:hover { color: #46C8F9; } .follow-links-1171966 li a.is,.follow-links-1171966 li a.is:hover { color: #D4C4A2; } #tncms-block-1171956 .tnt-prop-img { max-width: 508px; } #weather-1171981 .list-unstyled { margin: 0; } #weather-1171981 span { display: block; } #weather-1171981 .forecast-link a { padding: 8px; margin-top: -10px; } #weather-1171981 .icon { position: relative; } #weather-1171981 .icon .tnt-svg { position: relative; font-size: 52px; margin-bottom: -6px; margin-right: 5px; margin-top: -8px; } #weather-1171981 .temp { font-size: 24px; line-height: 24px; margin-top: 4px; font-weight: bold; } #weather-1171981 .cond { opacity: 0.7; } #weather-1171981 .current-conditions { float: left; height: 48px; } #weather-1171981 .dropdown-toggle { color: #333; display: block; } #weather-1171981 .city-title { padding-top: 5px; } #weather-1171981 .weather-expanded { padding: 0 15px; width: 300px; font-weight: normal; } #weather-1171981 .weather-expanded h5 { border-top: 1px solid rgba(0,0,0,.05); padding-top: 10px; } #weather-1171981 .weather-expanded small { opacity: 0.5; } #weather-1171981 .zip-update-form { width: 140px; margin-top: -54px; background-color: #eee; padding: 5px; position: absolute; display: none; right: 0; } #weather-1171981 .zip-update { width: 75px; } #weather-1171981 .zip-update-link { color: #999; font-size: 18px; text-decoration: none; } #weather-1171981 .zip-update-link:hover { color: #777; } #block-1171962 .search-spinner { position: absolute; } #block-1171962 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #tncms-block-1171957 .tnt-prop-img { max-width: 508px; } #ad-1171879 { min-height: 90px; min-width: 728px; } #block-1171959 .most-popular .tab-text { display: none; } #block-1171959 .most-popular .active .tab-text { display: inline; } #ad-1171876 { min-height: 250px; min-width: 300px; } #ad-1171877 { min-height: 250px; min-width: 300px; } #ad-1171878 { min-height: 250px; min-width: 300px; } #ad-1171880 { min-height: 90px; min-width: 728px; } #tncms-block-1171958 .tnt-prop-img { max-width: 300px; } .follow-links-1171967 li { margin-right: 1px; padding: 0; } .follow-links-1171967 li a, .follow-links-1171967 li a:focus, .follow-links-1171967 li a:active { ; height: 36px; width: 36px; font-size: 24px; color: #fff!important; border-radius: 20px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1171967 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1171967 li a.fb,.follow-links-1171967 li a.fb:hover { color: #fff; background-color: #3A59A5; } .follow-links-1171967 li a.tw,.follow-links-1171967 li a.tw:hover { color: #fff; background-color: #46C8F9; } .follow-links-1171967 li a.is,.follow-links-1171967 li a.is:hover { color: #fff; background-color: #D4C4A2; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/news","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":321},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"e84959fa-740e-11eb-800e-5749e449e707","app":"editorial"},"google":{"ua":"UA-243604-10"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "6802,6801,4228,4278", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["meadow lake","double homicide","rudy romero","henry romero","jacob arnold","david mestas","samuel mestas","felicia anaya","valencia county sheriff's office","murder"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/245294876/news-bulletin.com//news';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], [728, 90]).addSize([992, 0], [728, 90]).addSize([1200, 0], [728, 90]).build();
                gptAdSlots['ad-1171879'] = googletag.defineSlot(adUnit, [728, 90], 'ad-1171879').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1171879'].setTargeting('pos', ['TOP_728x90_NB']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/ads/impressions.js?_dc=1613923520"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/ads/traffic.js?_dc=1613892919"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/ads/settings.js?_dc=1519931522"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/245294876/news-bulletin.com//news';
            
                gptAdSlots['ad-1171876'] = googletag.defineSlot(adUnit, [300, 250], 'ad-1171876').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1171876'].setTargeting('pos', ['RR2_300x250_NB']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/245294876/news-bulletin.com//news';
            
                gptAdSlots['ad-1171877'] = googletag.defineSlot(adUnit, [300, 250], 'ad-1171877').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1171877'].setTargeting('pos', ['RR3_300x250_NB']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/245294876/news-bulletin.com//news';
            
                gptAdSlots['ad-1171878'] = googletag.defineSlot(adUnit, [300, 250], 'ad-1171878').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1171878'].setTargeting('pos', ['RR4_300x250_NB']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/245294876/news-bulletin.com//news';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], [728, 90]).addSize([992, 0], [728, 90]).addSize([1200, 0], [728, 90]).build();
                gptAdSlots['ad-1171880'] = googletag.defineSlot(adUnit, [728, 90], 'ad-1171880').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1171880'].setTargeting('pos', ['BOTTOM_728x90_NB']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Four suspects in custody for Meadow Lake double homicide | News | news-bulletin.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #026233; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #f7f7f7; } .fixed-nav #main-navigation { background-color: #f7f7f7 !important; } #site-top-nav-container, #site-top-nav { background-color: #056418; } #site-footer { background-color: #ffffff; color: #333333; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #666; } .navbar-toggle .icon-bar { background-color: #666 !important; } .navbar-toggle .sr-only-show { color: #666 !important; } #site-top-nav .list-inline>li>a { color: #010911; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #08641a; background-size: cover; background-position: 50% 0; }@media screen and (min-width: 992px) {#site-header { background-image: url(https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/34469f9e-7bb5-11e7-81fb-5fd62ad33a14.jpg?resize=1200%2C197) }}@media screen and (min-width: 1200px) {#site-header { background-image: url(https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/34469f9e-7bb5-11e7-81fb-5fd62ad33a14.jpg?resize=1700%2C279) }}/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #666; } }#site-copyright a, #site-footer a { color: #4175aa; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #026233; }#site-header{ border-bottom: 3px solid #026233; }#site-footer{ border-top: 3px solid #026233; } .tnt-bg-accent { background-color: #026233; } a .tnt-caret-down { color: #026233; } .block-title .block-title-inner { border-color: #026233; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #026233; } .form-control:focus { border-bottom-color: #026233; } #site-header .row {display: flex;align-items: center;width:100%;} #site-header .search-form-container {margin-bottom: 0;} #masthead-col-one {width: 45%;} #masthead-col-two {width: 25%;} #masthead-col-three {width: 30%;} .navbar-default .navbar-nav > li > a {padding-left:10px;padding-right:10px;} @media (min-width: 992px) and (max-width: 1200px){.navbar-default .navbar-nav > li > a {font-weight:normal;}} .text-muted {color: #026233;} .btn-primary {background-color: #026233;border-color: #026233;color: #fff;} .btn-primary:hover, .btn-primary:focus, .btn-primary.focus, .btn-primary:active, .btn-primary.active, .open > .dropdown-toggle.btn-primary {background-color: #037f43;border-color: #037f43;color: #fff;} #pg-bg-ad-container-left { display: block; float: none; height: 100%; left: 50%; margin-left: -804px; position: fixed; top: 0; width: 220px; } #pg-bg-ad-container-right { display: block; float: none; height: 100%; margin-right: -798px; position: fixed; right: 50%; top: 0; width: 213px; } #pg-bg-ad-container-left #full-pg-bg-left{ display:block; background-image: url("libraries/flex/components/site/resources/images/blank.gif"); width:220px; height:100%; } #pg-bg-ad-container-right #full-pg-bg-right{ display:block; background-image: url("libraries/flex/components/site/resources/images/blank.gif"); width:213px; height:100%; } #card-classifieds-categories-1055450 > div:nth-child(8) > div.card-headline.panel-heading > a > h3 > i.fa-tag:before { content: "\f24e"; } i.fa.fa-tag.fa-fw {display: none;} #tncms-block-1078941 {margin-bottom: 20px;text-align: center;} #tncms-block-1078941 .block-title {text-align: left;} .photo-carousel .item .photo-container {background-color: rgba(0, 0, 0, 0) !important;} .card .card-image .photo.layout-vertical {background-color: rgba(0, 0, 0, 0) !important;} .photo-carousel .photo-carousel-control {opacity: 1 !important;} </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="http://www.news-bulletin.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Four suspects in custody for Meadow Lake double homicide | News | news-bulletin.com" href="http://www.news-bulletin.com/search/?f=rss&amp;t=article&amp;c=news&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
<!-- code here -->


<script type="text/javascript">

$(document).bind("contextmenu", function(e) {   
       
        return false;
    });   
   
</script>

        </head>
        <body class="app-editorial grid-boxy blox-asset uuid-e84959fa-740e-11eb-800e-5749e449e707  section-news type-article infinity-disabled" data-path="/news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.news-bulletin.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=boxy&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=321&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=e84959fa-740e-11eb-800e-5749e449e707&amp;tncms.asset.app=editorial&amp;tncms.google.ua=UA-243604-10&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        
        
        
        <script>
            document.addEventListener("DOMContentLoaded", function(event) {
                __tnt.metering.access.d.push(function(){
                    //DMP logging
                    if(window._cc){
                        __tnt.log("Logging DMP data")
                        var paywallDmpData = 'Paywall : Viewed Paywall';
                        // Call to cms.dmp.js_behavior_action is here
                        
                    }
                });
            });
        </script>
    

    <div id="template-metering" data-message-mode="basic">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox regissub subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!
                </h4>

                <p>Please purchase a subscription to read our premium content. If you have a subscription, please log in or sign up for an account on our website to continue.
</p>

                
                <div class="col-xs-12">
                    <div class="pull-right">
                        <a class="btn btn-default btn-block meter-modal-open">Purchase a Subscription</a>
                    </div>
                </div>
                
            </div>
        </div>
        </div>
</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="https://www.news-bulletin.com/users/signup/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.news-bulletin.com/users/login/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://www.news-bulletin.com/users/admin/service/purchase/?referer_url=http%253A%252F%252Fwww.news-bulletin.com%252Fnews%252Ffour-suspects-in-custody-for-meadow-lake-double-homicide%252Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
    <template class="template meter access" data-count="1">
        <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox first free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
         
        <p><strong>Welcome!</strong> We hope that you enjoy our free content.</p>
    </div>
</template>
    
    <template class="template meter access" data-count="5" data-registered="false">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox login prompt">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
        
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.news-bulletin.com/users/login/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.news-bulletin.com/users/signup/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.news-bulletin.com/users/admin/service/purchase/?referer_url=http%253A%252F%252Fwww.news-bulletin.com%252Fnews%252Ffour-suspects-in-custody-for-meadow-lake-double-homicide%252Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">purchase a subscription</a></span> to continue reading.</p>
        </div>
</template>
    
    <template class="template meter access" data-count="5">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox last free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.news-bulletin.com/users/login/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.news-bulletin.com/users/signup/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.news-bulletin.com/users/admin/service/purchase/?referer_url=http%253A%252F%252Fwww.news-bulletin.com%252Fnews%252Ffour-suspects-in-custody-for-meadow-lake-double-homicide%252Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">purchase a subscription</a></span> to continue reading.</p>
    </div>
</template>
    
    <template class="template meter access" data-registered="true" data-after-wall="true">
        <div class="meter notification alert alert-dismissable alert-info" data-message="blox after login">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for signing in!</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="blox modal subscription">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Thank you for reading!
</h4>
            </div>

            <div class="modal-body">
                <div class="row">
                    <div class="col-xs-12">
                    <div class="not-logged-in">
                            <p>Please log in, or sign up for a new account and purchase a subscription to continue reading.
</p>
                        </div>
            
                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Please purchase a subscription to continue reading.
</p>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.
</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    
    <a  class="btn btn-default btn-block" href="https://www.news-bulletin.com/users/signup/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">Sign Up</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-primary btn-block" href="https://www.news-bulletin.com/users/login/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">Log In</a>
                                </div>
                            </div>
                        </div>
                    <div class="col-xs-12">
                            <div class="row logged-in">
                                <div class="pull-right">
                                    <a class="btn btn-default" href="https://www.news-bulletin.com/users/admin/service/purchase/?referer_url=http%253A%252F%252Fwww.news-bulletin.com%252Fnews%252Ffour-suspects-in-custody-for-meadow-lake-double-homicide%252Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">Purchase a Subscription
</a>
                                </div>
                            </div>
                            </div>
                        
                        
                    </div>
                </div>
            </div>
            <div class="modal-footer">
                
            </div>
        </div>
    </div>
</div>

<script>
var promoOpenedFromModal = false;
$(function(){
    $('#service-promo-open').on('submit',function(){
    
        if($('#service-promo-open').find('input[name=promo]').val()!=""){
            $('#service-promo-modal').find('input[name=promo]').val($('#service-promo-open').find('input[name=promo]').val());
            $('#service-promo-modal').find('.promo-loading').show();
    
            if($('#subscription-modal').is(':visible')){
                $('#subscription-modal').modal('toggle');
                promoOpenedFromModal = true;
                setTimeout(function () {
                    $('#service-promo-modal').find('.modal').modal('toggle').submit();
                },500);
            }else{
                $('#service-promo-modal').find('.modal').modal('toggle').submit();
            }
       }
    
        return false;
    });
    
    if($("#service-promo-open").find("input[name=promo]").val()!=""){
        setTimeout(function () {
            $("#service-promo-open").find("button").click();
        },500);
    }
    
});
</script>

<form id="service-promo-modal" class="" method="post" action="http://www.news-bulletin.com/content/tncms/live/" data-endpoint="http://www.news-bulletin.com/tncms/subscription/services/?promoCode=">
    <input type="hidden" name="serviceid" value=""/>
    <input type="hidden" name="referer_url" value="/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"/>

    <div class="modal fade">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                    <div class="form-group">
                        <label class="" for="promo">Have a promo code?</label>
                    </div>
                    <div class="form-group">
                        <div class="input-group">
                            <input type="text" class="form-control" name="promo" placeholder="Enter Code" value="">
                            <span class="input-group-btn"><button type="submit" class="btn btn-primary">Find Offers</button></span>
                        </div>
                    </div>
                </div>
                <div class="modal-body">
                    <template class="template promo-not-found-template">
                        <div class="promo-not-found-warning alert alert-warning">
    <p><strong>Sorry</strong>, no promotional deals were found matching that code.</p>
</div></template>
                    <template class="template promo-found-message-template">
                        <div class="promo-found-message alert alert-success clearfix">
    <p><strong>Promotional Rates</strong> were found for your code.
    
    </p>
</div></template>
                    <template class="template promo-error-template">
                        <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template>
                    
                    <div class="row">
                    <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div class="col-xs-12 service-promo-status-message"></div>
                    <div class="col-xs-12 output"></div>
                    </div>
                    
                    <template class="template-promo-service hide">
                        <div class="promotion-service subscription-service panel panel-default">
                            <h3 class="panel-heading"></h3>
                            <div class="panel-body">
                                <div class="service-note alert alert-info"></div>
                                <p class="description"></p>
                                <div class="rate-output"><p class="hide">do not remove</p></div>
                            </div>
                        </div>
                    </template>
                    <template class="template-promo-rate hide">
                        <div class="promotion subscription-service panel panel-default">
                            <div class="panel-body">
                                <h4 class="rate-name"></h4>
                                <div class="clearfix">
                                    <span class="pull-left">
                                        <div class="terms-automatic">
                                            <strong><span class="price"></span> <span class="duration"></span></strong>
                                            <small class="fine-print"></small>
                                        </div>
                                        <div class="terms-manual"></div>
                                    </span>
                                    <a data-subscription-service="" class="pull-right btn btn-primary rate-link">Get Started</a>
                                </div>
                            </div>
                        </div>
                    </template>

                </div>
                <div class="modal-footer">
                    <button type="button" class="btn btn-default pull-left" data-dismiss="modal">Back</button>
                </div>
            </div>
        </div>
    </div>
</form>
<script>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</script><script>

    $(function(){
        $('#service-promo-modal').on('submit',function(){
            var promoEl = $('#service-promo-modal');
            var promoVal = promoEl.find('input[name=promo]').val();
        
            __tnt.subscription.promos.fetch(promoEl, promoVal);
            
            $("#service-promo-modal").find("[data-dismiss=modal]").on('click',function(){
                if(promoOpenedFromModal){ 
                    $("#template-metering").find('.metering-modal').first().modal();
                    promoOpenedFromModal = true;
                }
            });

            return false;
        });
    });
</script>

<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
        $('#eedition-subscription').find('.meter-modal-open').on('click',function(){
            $("#template-metering").find('.metering-modal').first().modal();
        });
    });
    
</script>

    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(6802);
                
                bloxServiceIDs.push(6801);
                
                bloxServiceIDs.push(4228);
                
                bloxServiceIDs.push(4278);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.news-bulletin.com/tncms/admin/editorial-asset/?edit=e84959fa-740e-11eb-800e-5749e449e707"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1171979" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1171979" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.news-bulletin.com/users/signup/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.news-bulletin.com/users/login/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.news-bulletin.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1171979').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.news-bulletin.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.news-bulletin.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.news-bulletin.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1171979').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.news-bulletin.com/users/logout/" id="user-logout-form-1171979"><input type="hidden" name="referer_url" value="http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1171978" class="tncms-block"><div id="user-controls-1171978" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.news-bulletin.com/users/signup/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.news-bulletin.com/users/login/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.news-bulletin.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1171978').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.news-bulletin.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.news-bulletin.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.news-bulletin.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1171978').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.news-bulletin.com/users/logout/" id="user-logout-form-1171978"><input type="hidden" name="referer_url" value="http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1171966" class="tncms-block"><div class="follow-links-1171966 pull-right">
    
    <section id="block-1171966" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/valenciacountynewsbulletin" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/VCNewsBulletin" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/vcnewsbulletin/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.news-bulletin.com",
  "sameAs" : ["https://www.facebook.com/valenciacountynewsbulletin","https://twitter.com/VCNewsBulletin","https://www.instagram.com/vcnewsbulletin/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1171956" class="tncms-block"><section id="block-1171956" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/8974b238-2bd7-11e5-ad1b-13a6b8b3fa49.png?resize=200%2C43 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/8974b238-2bd7-11e5-ad1b-13a6b8b3fa49.png?resize=300%2C64 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/8974b238-2bd7-11e5-ad1b-13a6b8b3fa49.png?resize=400%2C85 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/8974b238-2bd7-11e5-ad1b-13a6b8b3fa49.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1171981" class="tncms-block"><div id="weather-1171981" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=87002" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">43&deg;</span>
                    
                        <span class="cond">Sunny <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="87002"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1171981 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Belen, NM
                                
                                 <small>(87002)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Sunny skies. Becoming windy late. High around 50F. Winds NNW at 20 to 30 mph..</p>
                            <h5>Tonight</h5>
                            <p>Clear skies. Low 22F. Winds NW at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: February 21, 2021 @ 9:01 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=87002"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1171962" class="tncms-block"><section id="block-1171962" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1171962" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-1171962" aria-labelledby="site-search-button-1171962" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
        <input type="hidden" name="nfl" value="ap">
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-lg ">
        <input id="site-search-1171962-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1171962-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1171962" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1171962-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1171962').submit();
        return false;
    });

    $('#site-search-1171962').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1171962 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1171962 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1171962-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                        <button  type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse" aria-expanded="false">
                            <span class="visible-sm sr-only-show">Sections</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_dropdown">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1171957" class="tncms-block"><section id="block-1171957" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/91ff3a90-2bd7-11e5-a00a-abac9757d8e6.png?resize=200%2C34 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/91ff3a90-2bd7-11e5-a00a-abac9757d8e6.png?resize=300%2C51 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/91ff3a90-2bd7-11e5-a00a-abac9757d8e6.png?resize=400%2C68 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/91ff3a90-2bd7-11e5-a00a-abac9757d8e6.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link   tnt-section-log-in"  href="/users/login"  tabindex="0">
                    <span class="nav-label">Log In</span>
                </a></li></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-business"  href="/news/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-education"  href="/news/education"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-features"  href="/news/features/"  tabindex="0">
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link   tnt-section-arts-entertainment"  href="/news/arts_and_entertainment/"  tabindex="0">
                    <span class="nav-label">Arts & Entertainment</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/community/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters"  href="/opinion/letters_to_editor/"  tabindex="0">
                    <span class="nav-label">Letters</span>
                </a></li><li>
                <a class="nav-link   tnt-section-columns"  href="/opinion/columns/"  tabindex="0">
                    <span class="nav-label">Columns</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-births"  href="/community/births"  tabindex="0">
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link   tnt-section-engagements"  href="/community/engagements"  tabindex="0">
                    <span class="nav-label">Engagements</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weddings"  href="/community/weddings"  tabindex="0">
                    <span class="nav-label">Weddings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-anniversaries"  href="/community/anniversaries"  tabindex="0">
                    <span class="nav-label">Anniversaries</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-noticias"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Noticias</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=NEWS-BULLETIN&amp;publisher_url:news-bulletin.com#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link   tnt-section-special-sections"  href="/special/"  tabindex="0">
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-archives"  href="/search"  tabindex="0">
                    <span class="nav-label">Archives</span>
                </a></li><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="https://classifiedsnm.com/marketplace/news-bulletin/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-legals"  href="/legals"  tabindex="0">
                    <span class="nav-label">Legals</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1171879" class="tncms-block hidden-xs"><div class="tnt-ads-container text-center  " >
        <div id="ad-1171879" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1171879');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1171868" class="tncms-block visible-xs"><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.news-bulletin.com",
  secureDomain: "news-bulletin.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-e84959fa-740e-11eb-800e-5749e449e707" class="asset article-default"  data-url="http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/e/84/e84959fa-740e-11eb-800e-5749e449e707/60320069a886e.preview.jpg?crop=823%2C437%2C11%2C54&resize=823%2C437&order=crop%2Cresize">
            <meta itemprop="width" content="823">
            <meta itemprop="height" content="437">
        </div>
        <meta itemprop="name" content="news-bulletin.com">
    </div>
    <link itemprop="mainEntityOfPage" href="http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html" />
    <style>
                .asset-paging .direction {
                    color: #026233;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"http:\/\/www.news-bulletin.com\/tncms\/search\/mlt\/?origin=e84959fa-740e-11eb-800e-5749e449e707&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"e84959fa-740e-11eb-800e-5749e449e707","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-e84959fa-740e-11eb-800e-5749e449e707" class="asset-paging">
                <div id="paging-prev-e84959fa-740e-11eb-800e-5749e449e707" class="paging-link prev offset"></div>
                <div id="paging-next-e84959fa-740e-11eb-800e-5749e449e707" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="tnt-flag label label-flag label-flag-breaking label-flag-breaking">breaking</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Four suspects in custody for Meadow Lake double homicide
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-02-20T23:34:00-07:00" class="tnt-date asset-date text-muted">
            Feb 20, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-02-20T23:34:00-07:00" class="tnt-date asset-date text-muted">9 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-02-20T23:34:00-07:00">
    <meta itemprop="datePublished" content="2021-02-20T23:34:00-07:00">
    <meta itemprop="dateModified" content="2021-02-20T23:34:00-07:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Four%20suspects%20in%20custody%20for%20Meadow%20Lake%20double%20homicide&url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.news-bulletin.com/tncms/asset/editorial/e84959fa-740e-11eb-800e-5749e449e707" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BValencia%20County%20News-Bulletin%5D%20Four%20suspects%20in%20custody%20for%20Meadow%20Lake%20double%20homicide&body=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="e84959fa-740e-11eb-800e-5749e449e707">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Four%20suspects%20in%20custody%20for%20Meadow%20Lake%20double%20homicide&url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.news-bulletin.com/tncms/asset/editorial/e84959fa-740e-11eb-800e-5749e449e707" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BValencia%20County%20News-Bulletin%5D%20Four%20suspects%20in%20custody%20for%20Meadow%20Lake%20double%20homicide&body=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-e84959fa-740e-11eb-800e-5749e449e707-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e84959fa-740e-11eb-800e-5749e449e707" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e84959fa-740e-11eb-800e-5749e449e707" class="save-list-e84959fa-740e-11eb-800e-5749e449e707-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e84959fa-740e-11eb-800e-5749e449e707" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>Four Los Lunas residents have been arrested and are in custody tonight in connection with a double homicide in Meadow Lake.</p></div><div class="subscriber-only"><p>Shortly before 2 a.m., Friday, Feb. 19, deputies with the Valencia County Sheriff's Office arrived at 298 Meadow Lake Road in response to a call about a disturbance at the residence.</p></div><div class="subscriber-only"><p>Deputies found two men dead in the home who had suffered multiple gunshot wounds.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>They were identified as brothers Rudy Romero, 32, and Henry Romero Jr., 38. Both men lived at the house, according to a press release from VCSO.</p></div><div class="subscriber-only"><p>Investigators learned four people — Felicia Anaya, 37; Jacob Arnold, 25; David Mestas, 29, and Samuel Mestas, 26, all of Los Lunas — had come to the home and a fight broke out in the front yard between the two groups.</p></div><div class="inline-asset inline-collection  subscriber-hide tnt-inline-asset tnt-inline-relcontent tnt-inline-collection tnt-inline-relation-child tnt-inline-presentation-mosaic tnt-inline-width-full">
        
        <div class="collection-header collection-header-mosaic">
            <h4><a href="/four-suspects-feb-19-meadow-lake-double-homicide/collection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html" title="Four suspects, Feb. 19 Meadow Lake double homicide">Four suspects, Feb. 19 Meadow Lake double homicide</a></h4>
        </div>
        <div class="modal fullscreen" id="photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" class="card photo-carousel    subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 4
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" class="carousel-inner"><div  class="item photo-452bb460-740f-11eb-b84a-07f41d7099df">
                            <div class="item-container">
				                <div data-track-object='{"title":"Four suspects, Feb. 19 Meadow Lake double homicide","url":"/four-suspects-feb-19-meadow-lake-double-homicide/collection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html","uuid":"1d054d74-7410-11eb-be47-13a1b89e4f1e","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=339%2C525%2C179%2C13"
                    
                    alt="Anaya,Felicia.png"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="339"
                    height="525"
                    data-src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=339%2C525%2C179%2C13" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target=".caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal collapse in"><div class="caption-text"><p><strong>Felicia Anaya</strong></p><p><em>In custody</em></p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share%231" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/anaya-felicia-png/image_452bb460-740f-11eb-b84a-07f41d7099df.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"452bb460-740f-11eb-b84a-07f41d7099df"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Anaya%2CFelicia.png&url=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share%231" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/anaya-felicia-png/image_452bb460-740f-11eb-b84a-07f41d7099df.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"452bb460-740f-11eb-b84a-07f41d7099df"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.news-bulletin.com/anaya-felicia-png/image_452bb460-740f-11eb-b84a-07f41d7099df.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/anaya-felicia-png/image_452bb460-740f-11eb-b84a-07f41d7099df.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"452bb460-740f-11eb-b84a-07f41d7099df"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.news-bulletin.com/tncms/asset/editorial/452bb460-740f-11eb-b84a-07f41d7099df" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"452bb460-740f-11eb-b84a-07f41d7099df"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BValencia%20County%20News-Bulletin%5D%20Anaya%2CFelicia.png&body=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share%231" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"452bb460-740f-11eb-b84a-07f41d7099df"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/anaya-felicia-png/image_452bb460-740f-11eb-b84a-07f41d7099df.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"452bb460-740f-11eb-b84a-07f41d7099df"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-452bb460-740f-11eb-b84a-07f41d7099df-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="452bb460-740f-11eb-b84a-07f41d7099df" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="452bb460-740f-11eb-b84a-07f41d7099df" class="save-list-452bb460-740f-11eb-b84a-07f41d7099df-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="452bb460-740f-11eb-b84a-07f41d7099df" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-467b3098-740f-11eb-9237-eb03789ef020">
                            <div class="item-container">
				                <div data-track-object='{"title":"Four suspects, Feb. 19 Meadow Lake double homicide","url":"/four-suspects-feb-19-meadow-lake-double-homicide/collection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html","uuid":"1d054d74-7410-11eb-be47-13a1b89e4f1e","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/67/467b3098-740f-11eb-9237-eb03789ef020/6031ffac135ac.image.png?crop=338%2C485%2C154%2C96"
                    
                    alt="Arnold,Jacob.png"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="338"
                    height="485"
                    data-src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/67/467b3098-740f-11eb-9237-eb03789ef020/6031ffac135ac.image.png?crop=338%2C485%2C154%2C96" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target=".caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal collapse in"><div class="caption-text"><p><strong>Jacob Arnold</strong></p><p><em>In custody</em></p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share%232" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/arnold-jacob-png/image_467b3098-740f-11eb-9237-eb03789ef020.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"467b3098-740f-11eb-9237-eb03789ef020"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Arnold%2CJacob.png&url=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share%232" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/arnold-jacob-png/image_467b3098-740f-11eb-9237-eb03789ef020.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"467b3098-740f-11eb-9237-eb03789ef020"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.news-bulletin.com/arnold-jacob-png/image_467b3098-740f-11eb-9237-eb03789ef020.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/arnold-jacob-png/image_467b3098-740f-11eb-9237-eb03789ef020.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"467b3098-740f-11eb-9237-eb03789ef020"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.news-bulletin.com/tncms/asset/editorial/467b3098-740f-11eb-9237-eb03789ef020" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"467b3098-740f-11eb-9237-eb03789ef020"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BValencia%20County%20News-Bulletin%5D%20Arnold%2CJacob.png&body=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share%232" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"467b3098-740f-11eb-9237-eb03789ef020"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/arnold-jacob-png/image_467b3098-740f-11eb-9237-eb03789ef020.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"467b3098-740f-11eb-9237-eb03789ef020"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-467b3098-740f-11eb-9237-eb03789ef020-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="467b3098-740f-11eb-9237-eb03789ef020" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="467b3098-740f-11eb-9237-eb03789ef020" class="save-list-467b3098-740f-11eb-9237-eb03789ef020-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="467b3098-740f-11eb-9237-eb03789ef020" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-47cbf888-740f-11eb-bdc2-fb01150ac1b3">
                            <div class="item-container">
				                <div data-track-object='{"title":"Four suspects, Feb. 19 Meadow Lake double homicide","url":"/four-suspects-feb-19-meadow-lake-double-homicide/collection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html","uuid":"1d054d74-7410-11eb-be47-13a1b89e4f1e","app":"editorial","metric":""}'  data-count="3"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Mestas,David.png"
                    class="img-responsive owl-lazy default"
                    width="336"
                    height="519"
                    data-src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/7c/47cbf888-740f-11eb-bdc2-fb01150ac1b3/6031ffae45e87.image.png?crop=336%2C519%2C86%2C51" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target=".caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal collapse in"><div class="caption-text"><p><strong>David Mestas</strong></p><p><em>In custody</em></p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share%233" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/mestas-david-png/image_47cbf888-740f-11eb-bdc2-fb01150ac1b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"47cbf888-740f-11eb-bdc2-fb01150ac1b3"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Mestas%2CDavid.png&url=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share%233" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/mestas-david-png/image_47cbf888-740f-11eb-bdc2-fb01150ac1b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"47cbf888-740f-11eb-bdc2-fb01150ac1b3"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.news-bulletin.com/mestas-david-png/image_47cbf888-740f-11eb-bdc2-fb01150ac1b3.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/mestas-david-png/image_47cbf888-740f-11eb-bdc2-fb01150ac1b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"47cbf888-740f-11eb-bdc2-fb01150ac1b3"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.news-bulletin.com/tncms/asset/editorial/47cbf888-740f-11eb-bdc2-fb01150ac1b3" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"47cbf888-740f-11eb-bdc2-fb01150ac1b3"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BValencia%20County%20News-Bulletin%5D%20Mestas%2CDavid.png&body=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share%233" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"47cbf888-740f-11eb-bdc2-fb01150ac1b3"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/mestas-david-png/image_47cbf888-740f-11eb-bdc2-fb01150ac1b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"47cbf888-740f-11eb-bdc2-fb01150ac1b3"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-47cbf888-740f-11eb-bdc2-fb01150ac1b3-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="47cbf888-740f-11eb-bdc2-fb01150ac1b3" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="47cbf888-740f-11eb-bdc2-fb01150ac1b3" class="save-list-47cbf888-740f-11eb-bdc2-fb01150ac1b3-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="47cbf888-740f-11eb-bdc2-fb01150ac1b3" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-49103132-740f-11eb-b62e-3bc07f57806b">
                            <div class="item-container">
				                <div data-track-object='{"title":"Four suspects, Feb. 19 Meadow Lake double homicide","url":"/four-suspects-feb-19-meadow-lake-double-homicide/collection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html","uuid":"1d054d74-7410-11eb-be47-13a1b89e4f1e","app":"editorial","metric":""}'  data-count="4"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Mestas,Samuel2.png"
                    class="img-responsive owl-lazy default"
                    width="339"
                    height="513"
                    data-src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/91/49103132-740f-11eb-b62e-3bc07f57806b/6031ffb0644ee.image.png?crop=339%2C513%2C118%2C35" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target=".caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal collapse in"><div class="caption-text"><p><strong>Samuel Mestas</strong></p><p><em>In custody</em></p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share%234" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/mestas-samuel2-png/image_49103132-740f-11eb-b62e-3bc07f57806b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"49103132-740f-11eb-b62e-3bc07f57806b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Mestas%2CSamuel2.png&url=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share%234" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/mestas-samuel2-png/image_49103132-740f-11eb-b62e-3bc07f57806b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"49103132-740f-11eb-b62e-3bc07f57806b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.news-bulletin.com/mestas-samuel2-png/image_49103132-740f-11eb-b62e-3bc07f57806b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/mestas-samuel2-png/image_49103132-740f-11eb-b62e-3bc07f57806b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"49103132-740f-11eb-b62e-3bc07f57806b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.news-bulletin.com/tncms/asset/editorial/49103132-740f-11eb-b62e-3bc07f57806b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"49103132-740f-11eb-b62e-3bc07f57806b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BValencia%20County%20News-Bulletin%5D%20Mestas%2CSamuel2.png&body=https%3A%2F%2Fwww.news-bulletin.com%2Ffour-suspects-feb-19-meadow-lake-double-homicide%2Fcollection_1d054d74-7410-11eb-be47-13a1b89e4f1e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share%234" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"49103132-740f-11eb-b62e-3bc07f57806b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/mestas-samuel2-png/image_49103132-740f-11eb-b62e-3bc07f57806b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"49103132-740f-11eb-b62e-3bc07f57806b"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-49103132-740f-11eb-b62e-3bc07f57806b-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="49103132-740f-11eb-b62e-3bc07f57806b" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="49103132-740f-11eb-b62e-3bc07f57806b" class="save-list-49103132-740f-11eb-b62e-3bc07f57806b-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="49103132-740f-11eb-b62e-3bc07f57806b" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div><div class="card-container">
                <div class="mosaic-grid row row-seamless">
                    <div class="col-sm-6 col-md-3 mosaic-main-col"><div class="mosaic-item-container  hover-expand "  data-toggle="modal" data-photo-target=".photo-452bb460-740f-11eb-b84a-07f41d7099df" data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e"><span class="expand">
                   +3&nbsp;
                   <span class="fas tnt-camera"></span></span>
        
        <div class="mosaic-item card mosaic-overlay- mosaic-hover- img-responsive lazyload">
            
            
                <div class="media-preview-452bb460-740f-11eb-b84a-07f41d7099df media-preview image-asset" data-aspect=""><figure class="photo layout-vertical hover-expand "><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-452bb460-740f-11eb-b84a-07f41d7099df" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                       +3&nbsp;
                       <span class="fas tnt-camera"></span></span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-452bb460-740f-11eb-b84a-07f41d7099df" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Image"></i></div>
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="339">
            <meta itemprop="height" content="525">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=339%2C525%2C179%2C13">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=339%2C525%2C179%2C13">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Anaya,Felicia.png"
                            class="img-responsive lazyload full default"
                            width="339"
                            height="525"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=339%2C525%2C179%2C13&resize=200%2C310&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=339%2C525%2C179%2C13&resize=300%2C465&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=339%2C525%2C179%2C13&resize=339%2C525&order=crop%2Cresize 400w" />
            </div>
                
                
            </div>
            
        </figure></div>
            
            
            <div class="meta">
                
                
                
                
                
                
            </div></div>
    </div></div>
                    <div class="col-sm-6 col-md-3 mosaic-col"><div class="mosaic-item-container  hover-expand "  data-toggle="modal" data-photo-target=".photo-467b3098-740f-11eb-9237-eb03789ef020" data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e"><span class="expand">
                   +3&nbsp;
                   <span class="fas tnt-camera"></span></span>
        
        <div class="mosaic-item card mosaic-overlay- mosaic-hover- img-responsive lazyload">
            
            
                <div class="media-preview-467b3098-740f-11eb-9237-eb03789ef020 media-preview image-asset" data-aspect=""><figure class="photo layout-vertical hover-expand "><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-467b3098-740f-11eb-9237-eb03789ef020" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                       +3&nbsp;
                       <span class="fas tnt-camera"></span></span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-467b3098-740f-11eb-9237-eb03789ef020" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Image"></i></div>
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="338">
            <meta itemprop="height" content="485">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/67/467b3098-740f-11eb-9237-eb03789ef020/6031ffac135ac.image.png?crop=338%2C485%2C154%2C96">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/67/467b3098-740f-11eb-9237-eb03789ef020/6031ffac135ac.image.png?crop=338%2C485%2C154%2C96">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Arnold,Jacob.png"
                            class="img-responsive lazyload full default"
                            width="338"
                            height="485"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/67/467b3098-740f-11eb-9237-eb03789ef020/6031ffac135ac.image.png?crop=338%2C485%2C154%2C96&resize=200%2C287&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/67/467b3098-740f-11eb-9237-eb03789ef020/6031ffac135ac.image.png?crop=338%2C485%2C154%2C96&resize=300%2C430&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/67/467b3098-740f-11eb-9237-eb03789ef020/6031ffac135ac.image.png?crop=338%2C485%2C154%2C96&resize=338%2C485&order=crop%2Cresize 400w" />
            </div>
                
                
            </div>
            
        </figure></div>
            
            
            <div class="meta">
                
                
                
                
                
                
            </div></div>
    </div></div>
                    <div class="col-sm-6 col-md-3 mosaic-col"><div class="mosaic-item-container  hover-expand "  data-toggle="modal" data-photo-target=".photo-47cbf888-740f-11eb-bdc2-fb01150ac1b3" data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e"><span class="expand">
                   +3&nbsp;
                   <span class="fas tnt-camera"></span></span>
        
        <div class="mosaic-item card mosaic-overlay- mosaic-hover- img-responsive lazyload">
            
            
                <div class="media-preview-47cbf888-740f-11eb-bdc2-fb01150ac1b3 media-preview image-asset" data-aspect=""><figure class="photo layout-vertical hover-expand "><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-47cbf888-740f-11eb-bdc2-fb01150ac1b3" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                       +3&nbsp;
                       <span class="fas tnt-camera"></span></span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-47cbf888-740f-11eb-bdc2-fb01150ac1b3" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Image"></i></div>
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="336">
            <meta itemprop="height" content="519">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/7c/47cbf888-740f-11eb-bdc2-fb01150ac1b3/6031ffae45e87.image.png?crop=336%2C519%2C86%2C51">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/7c/47cbf888-740f-11eb-bdc2-fb01150ac1b3/6031ffae45e87.image.png?crop=336%2C519%2C86%2C51">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Mestas,David.png"
                            class="img-responsive lazyload full default"
                            width="336"
                            height="519"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/7c/47cbf888-740f-11eb-bdc2-fb01150ac1b3/6031ffae45e87.image.png?crop=336%2C519%2C86%2C51&resize=200%2C309&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/7c/47cbf888-740f-11eb-bdc2-fb01150ac1b3/6031ffae45e87.image.png?crop=336%2C519%2C86%2C51&resize=300%2C463&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/7c/47cbf888-740f-11eb-bdc2-fb01150ac1b3/6031ffae45e87.image.png?crop=336%2C519%2C86%2C51&resize=336%2C519&order=crop%2Cresize 400w" />
            </div>
                
                
            </div>
            
        </figure></div>
            
            
            <div class="meta">
                
                
                
                
                
                
            </div></div>
    </div></div>
                    <div class="col-sm-6 col-md-3 mosaic-col"><div class="mosaic-item-container  hover-expand "  data-toggle="modal" data-photo-target=".photo-49103132-740f-11eb-b62e-3bc07f57806b" data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e"><span class="expand">
                   +3&nbsp;
                   <span class="fas tnt-camera"></span></span>
        
        <div class="mosaic-item card mosaic-overlay- mosaic-hover- img-responsive lazyload">
            
            
                <div class="media-preview-49103132-740f-11eb-b62e-3bc07f57806b media-preview image-asset" data-aspect=""><figure class="photo layout-vertical hover-expand "><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-49103132-740f-11eb-b62e-3bc07f57806b" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                       +3&nbsp;
                       <span class="fas tnt-camera"></span></span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-49103132-740f-11eb-b62e-3bc07f57806b" 
                    data-instance="#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal" 
                    data-target="#photo-carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Image"></i></div>
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="339">
            <meta itemprop="height" content="513">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/91/49103132-740f-11eb-b62e-3bc07f57806b/6031ffb0644ee.image.png?crop=339%2C513%2C118%2C35">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/91/49103132-740f-11eb-b62e-3bc07f57806b/6031ffb0644ee.image.png?crop=339%2C513%2C118%2C35">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Mestas,Samuel2.png"
                            class="img-responsive lazyload full default"
                            width="339"
                            height="513"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/91/49103132-740f-11eb-b62e-3bc07f57806b/6031ffb0644ee.image.png?crop=339%2C513%2C118%2C35&resize=200%2C303&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/91/49103132-740f-11eb-b62e-3bc07f57806b/6031ffb0644ee.image.png?crop=339%2C513%2C118%2C35&resize=300%2C454&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/91/49103132-740f-11eb-b62e-3bc07f57806b/6031ffb0644ee.image.png?crop=339%2C513%2C118%2C35&resize=339%2C513&order=crop%2Cresize 400w" />
            </div>
                
                
            </div>
            
        </figure></div>
            
            
            <div class="meta">
                
                
                
                
                
                
            </div></div>
    </div></div>
                </div>
    </div></div><div class="subscriber-only"><p>Detectives were told the fight was initially about stolen property, and at some point during the altercation, several shots were fired.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>As deputies arrived at the home, Anaya fled on foot and was apprehended after a brief foot pursuit. She was booked into the Valencia County Detention Center on two open counts of murder.</p></div><div class="subscriber-only"><p>The three male suspects appeared to have fled the scene by vehicle prior to deputies arriving. Arrest warrants for the men were obtained and the Valencia County Sheriff’s Office asked for the assistance of the United States Marshals Service in their apprehension.</p></div><div class="subscriber-only"><p>At about 6 p.m. today, Saturday, Feb. 20, David and Samuel Mestas turned themselves in at the Los Lunas Police Department.</p></div><div class="subscriber-only"><p>At 6:30 p.m. today, U.S. Marshals, along with VCSO detectives, located Arnold at his home in El Cerro Mission. He was taken into custody without incident.</p></div><div class="subscriber-only"><p>The three men were transported to the sheriff’s office where they were further processed and then booked into the Valencia County Detention Center on two open counts of murder.</p></div><div class="subscriber-only"><p>“The sheriff’s office would like to thank the marshals service for their assistance in the quick apprehension of the suspects in this case,” said Lt. Joseph Rowland, VCSO spokesman.</p></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Four%20suspects%20in%20custody%20for%20Meadow%20Lake%20double%20homicide&url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.news-bulletin.com/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.news-bulletin.com/tncms/asset/editorial/e84959fa-740e-11eb-800e-5749e449e707" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BValencia%20County%20News-Bulletin%5D%20Four%20suspects%20in%20custody%20for%20Meadow%20Lake%20double%20homicide&body=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e84959fa-740e-11eb-800e-5749e449e707"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-e84959fa-740e-11eb-800e-5749e449e707-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e84959fa-740e-11eb-800e-5749e449e707" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e84959fa-740e-11eb-800e-5749e449e707" class="save-list-e84959fa-740e-11eb-800e-5749e449e707-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e84959fa-740e-11eb-800e-5749e449e707" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22meadow%20lake%22#tncms-source=keyword" class="tag-meadow-lake label label-default" >Meadow Lake</a>
            </li> <li>
                <a href="/search/?k=%22double%20homicide%22#tncms-source=keyword" class="tag-double-homicide label label-default" >Double Homicide</a>
            </li> <li>
                <a href="/search/?k=%22rudy%20romero%22#tncms-source=keyword" class="tag-rudy-romero label label-default" >Rudy Romero</a>
            </li> <li>
                <a href="/search/?k=%22henry%20romero%22#tncms-source=keyword" class="tag-henry-romero label label-default" >Henry Romero</a>
            </li> <li>
                <a href="/search/?k=%22jacob%20arnold%22#tncms-source=keyword" class="tag-jacob-arnold label label-default" >Jacob Arnold</a>
            </li> <li>
                <a href="/search/?k=%22david%20mestas%22#tncms-source=keyword" class="tag-david-mestas label label-default" >David Mestas</a>
            </li> <li>
                <a href="/search/?k=%22samuel%20mestas%22#tncms-source=keyword" class="tag-samuel-mestas label label-default" >Samuel Mestas</a>
            </li> <li>
                <a href="/search/?k=%22felicia%20anaya%22#tncms-source=keyword" class="tag-felicia-anaya label label-default" >Felicia Anaya</a>
            </li> <li>
                <a href="/search/?k=%22valencia%20county%20sheriff%27s%20office%22#tncms-source=keyword" class="tag-valencia-county-sheriffs-office label label-default" >Valencia County Sheriff's Office</a>
            </li> <li>
                <a href="/search/?k=%22murder%22#tncms-source=keyword" class="tag-murder label label-default" >Murder</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("832ed22d-3ce2-4937-9f93-e56306b8315c");
        var apiKey = "YDC2G9T2K4BXNCJ3XDMR";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-832ed22d-3ce2-4937-9f93-e56306b8315c';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="e84959fa-740e-11eb-800e-5749e449e707" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="e84959fa-740e-11eb-800e-5749e449e707" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.news-bulletin.com/users/login/?referer_url=http%3A%2F%2Fwww.news-bulletin.com%2Fnews%2Ffour-suspects-in-custody-for-meadow-lake-double-homicide%2Farticle_e84959fa-740e-11eb-800e-5749e449e707.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1171959" class="tncms-block"><section id="block-1171959" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1171959 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1171959" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1171959" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1171959" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1171959" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-square "><li><a href="/news/four-suspects-in-custody-for-meadow-lake-double-homicide/article_e84959fa-740e-11eb-800e-5749e449e707.html">Four suspects in custody for Meadow Lake double homicide</a></li><li><a href="/news/education/los-lunas-schools-to-remain-on-remote-learning/article_00624112-7155-11eb-8a70-c75902c70cca.html">Los Lunas Schools to remain on remote-learning</a></li><li><a href="/community/obituaries/obituaries/article_9aed1778-7148-11eb-8e24-d7e030bcf228.html">Obituaries</a></li><li><a href="/community/obituaries/obituaries/article_d1e16e80-6bcd-11eb-9152-d3c047e88cf0.html">Obituaries</a></li><li><a href="/news/business/facebook-looking-to-expand-data-center/article_1236c140-7157-11eb-ab0e-57716d18bd5b.html">Facebook looking to expand data center</a></li><li><a href="/news/sen-baca-criticized-for-racial-questioning/article_6d52d85a-715e-11eb-a4ad-8f6933e61ceb.html">Sen. Baca criticized for racial questioning</a></li><li><a href="/news/business/niagara-pulls-its-request-for-more-water/article_9452307a-7156-11eb-bf0e-43cbbde83337.html">Niagara pulls its request for more water</a></li><li><a href="/news/albuquerque-man-charged-in-meadow-lake-double-homicide/article_cb4657ae-6838-11eb-b7ec-171065828914.html">Albuquerque man charged in Meadow Lake double homicide</a></li><li><a href="/opinion/letters_to_editor/letters-to-the-editor/article_aea24148-7149-11eb-971e-cb06ce6b1a89.html">Letters to the Editor</a></li><li><a href="/sports/bhs-athletes-prepare-to-play/article_fb74bf30-714b-11eb-91f8-83b64bf25bfc.html">BHS athletes prepare to play</a></li></ul></div>
        
        
            <div id="images-1171959" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/niagaraprotest-3-col-jpg/image_916c1532-7157-11eb-844d-431e40b686a6.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="NiagaraProtest 3 COL.jpg"
                            class="img-responsive lazyload full default"
                            width="888"
                            height="888"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/16/916c1532-7157-11eb-844d-431e40b686a6/602d707815db6.image.jpg?crop=888%2C888%2C150%2C26&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/16/916c1532-7157-11eb-844d-431e40b686a6/602d707815db6.image.jpg?crop=888%2C888%2C150%2C26&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/16/916c1532-7157-11eb-844d-431e40b686a6/602d707815db6.image.jpg?crop=888%2C888%2C150%2C26&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/16/916c1532-7157-11eb-844d-431e40b686a6/602d707815db6.image.jpg?crop=888%2C888%2C150%2C26&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/16/916c1532-7157-11eb-844d-431e40b686a6/602d707815db6.image.jpg?crop=888%2C888%2C150%2C26&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/16/916c1532-7157-11eb-844d-431e40b686a6/602d707815db6.image.jpg?crop=888%2C888%2C150%2C26&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/16/916c1532-7157-11eb-844d-431e40b686a6/602d707815db6.image.jpg?crop=888%2C888%2C150%2C26&resize=888%2C888&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/obitgurule-jason-1-col-jpg/image_fec8bb12-7148-11eb-8edd-c7c7a6667868.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="obitGurule,Jason 1 COL.jpg"
                            class="img-responsive lazyload full default"
                            width="500"
                            height="500"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/f/ec/fec8bb12-7148-11eb-8edd-c7c7a6667868/602d58051b308.image.jpg?crop=500%2C500%2C0%2C152&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/f/ec/fec8bb12-7148-11eb-8edd-c7c7a6667868/602d58051b308.image.jpg?crop=500%2C500%2C0%2C152&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/f/ec/fec8bb12-7148-11eb-8edd-c7c7a6667868/602d58051b308.image.jpg?crop=500%2C500%2C0%2C152&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/f/ec/fec8bb12-7148-11eb-8edd-c7c7a6667868/602d58051b308.image.jpg?crop=500%2C500%2C0%2C152&resize=500%2C500&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/salazar-porfirio-jpg/image_a4d63b88-6839-11eb-b904-b3c0925f7806.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Salazar,Porfirio.JPG"
                            class="img-responsive lazyload full default"
                            width="516"
                            height="516"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/4d/a4d63b88-6839-11eb-b904-b3c0925f7806/601e24cb4a85a.image.jpg?crop=516%2C516%2C176%2C268&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/4d/a4d63b88-6839-11eb-b904-b3c0925f7806/601e24cb4a85a.image.jpg?crop=516%2C516%2C176%2C268&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/4d/a4d63b88-6839-11eb-b904-b3c0925f7806/601e24cb4a85a.image.jpg?crop=516%2C516%2C176%2C268&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/4d/a4d63b88-6839-11eb-b904-b3c0925f7806/601e24cb4a85a.image.jpg?crop=516%2C516%2C176%2C268&resize=516%2C516&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/llsportsrally2-2-col-jpg/image_b1542d76-6bcb-11eb-93bb-57c814abc5df.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="LLSportsRally2 2 COL.jpg"
                            class="img-responsive lazyload full default"
                            width="1000"
                            height="1000"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/b/15/b1542d76-6bcb-11eb-93bb-57c814abc5df/602422504198c.image.jpg?crop=1000%2C1000%2C0%2C196&resize=1000%2C1000&order=crop%2Cresize 1035w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/gilbert-wedding-3-bw-jpg/image_86eccfaa-6bcd-11eb-8021-23d696560155.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Gilbert wedding 3 BW.JPG"
                            class="img-responsive lazyload full default"
                            width="1282"
                            height="1282"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/6e/86eccfaa-6bcd-11eb-8021-23d696560155/602425641d7e0.image.jpg?crop=1282%2C1282%2C167%2C0&resize=1282%2C1282&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/online_features/money_and_finance/millions-face-uncertainty-in-navigating-unemployment-benefits-and-tax-filing/image_8d03ab1d-3a5c-560d-aef9-79e18b5363c9.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Millions Face Uncertainty in Navigating Unemployment Benefits and Tax Filing"
                            class="img-responsive lazyload full default"
                            width="720"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/d0/8d03ab1d-3a5c-560d-aef9-79e18b5363c9/602f854d306d4.image.jpg?crop=720%2C720%2C280%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/d0/8d03ab1d-3a5c-560d-aef9-79e18b5363c9/602f854d306d4.image.jpg?crop=720%2C720%2C280%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/d0/8d03ab1d-3a5c-560d-aef9-79e18b5363c9/602f854d306d4.image.jpg?crop=720%2C720%2C280%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/d0/8d03ab1d-3a5c-560d-aef9-79e18b5363c9/602f854d306d4.image.jpg?crop=720%2C720%2C280%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/d0/8d03ab1d-3a5c-560d-aef9-79e18b5363c9/602f854d306d4.image.jpg?crop=720%2C720%2C280%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/8/d0/8d03ab1d-3a5c-560d-aef9-79e18b5363c9/602f854d306d4.image.jpg?crop=720%2C720%2C280%2C0&resize=720%2C720&order=crop%2Cresize 750w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/anaya-felicia-png/image_452bb460-740f-11eb-b84a-07f41d7099df.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Anaya,Felicia.png"
                            class="img-responsive lazyload full default"
                            width="340"
                            height="339"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=340%2C339%2C179%2C106&resize=200%2C199&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=340%2C339%2C179%2C106&resize=300%2C299&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/4/52/452bb460-740f-11eb-b84a-07f41d7099df/6031ffa9d6f81.image.png?crop=340%2C339%2C179%2C106&resize=340%2C339&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/rotary-clothes/image_a8dd4ac2-6bd2-11eb-bd9d-e352ac63cc52.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Rotary Clothes"
                            class="img-responsive lazyload full default"
                            width="727"
                            height="727"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/8d/a8dd4ac2-6bd2-11eb-bd9d-e352ac63cc52/60242e50603ef.image.jpg?crop=727%2C727%2C336%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/8d/a8dd4ac2-6bd2-11eb-bd9d-e352ac63cc52/60242e50603ef.image.jpg?crop=727%2C727%2C336%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/8d/a8dd4ac2-6bd2-11eb-bd9d-e352ac63cc52/60242e50603ef.image.jpg?crop=727%2C727%2C336%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/8d/a8dd4ac2-6bd2-11eb-bd9d-e352ac63cc52/60242e50603ef.image.jpg?crop=727%2C727%2C336%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/8d/a8dd4ac2-6bd2-11eb-bd9d-e352ac63cc52/60242e50603ef.image.jpg?crop=727%2C727%2C336%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/a/8d/a8dd4ac2-6bd2-11eb-bd9d-e352ac63cc52/60242e50603ef.image.jpg?crop=727%2C727%2C336%2C0&resize=727%2C727&order=crop%2Cresize 750w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/obitarchuleta-salomon-1-col-jpg/image_979e00f8-60ce-11eb-817d-ab070ec2e706.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="obitArchuleta, Salomon 1 COL.jpg"
                            class="img-responsive lazyload full default"
                            width="500"
                            height="500"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/79/979e00f8-60ce-11eb-817d-ab070ec2e706/6011b2b6c81cc.image.jpg?crop=500%2C500%2C0%2C89&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/79/979e00f8-60ce-11eb-817d-ab070ec2e706/6011b2b6c81cc.image.jpg?crop=500%2C500%2C0%2C89&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/79/979e00f8-60ce-11eb-817d-ab070ec2e706/6011b2b6c81cc.image.jpg?crop=500%2C500%2C0%2C89&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/9/79/979e00f8-60ce-11eb-817d-ab070ec2e706/6011b2b6c81cc.image.jpg?crop=500%2C500%2C0%2C89&resize=500%2C500&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/vaccinesignup2-3-col-jpg/image_1ebfdf4e-664b-11eb-b34c-7bb14a3b5180.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="VaccineSignup2 3 COL.JPG"
                            class="img-responsive lazyload full default"
                            width="933"
                            height="933"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/1/eb/1ebfdf4e-664b-11eb-b34c-7bb14a3b5180/601ae71ee8ca5.image.jpg?crop=933%2C933%2C233%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/1/eb/1ebfdf4e-664b-11eb-b34c-7bb14a3b5180/601ae71ee8ca5.image.jpg?crop=933%2C933%2C233%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/1/eb/1ebfdf4e-664b-11eb-b34c-7bb14a3b5180/601ae71ee8ca5.image.jpg?crop=933%2C933%2C233%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/1/eb/1ebfdf4e-664b-11eb-b34c-7bb14a3b5180/601ae71ee8ca5.image.jpg?crop=933%2C933%2C233%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/1/eb/1ebfdf4e-664b-11eb-b34c-7bb14a3b5180/601ae71ee8ca5.image.jpg?crop=933%2C933%2C233%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/1/eb/1ebfdf4e-664b-11eb-b34c-7bb14a3b5180/601ae71ee8ca5.image.jpg?crop=933%2C933%2C233%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/assets/v3/editorial/1/eb/1ebfdf4e-664b-11eb-b34c-7bb14a3b5180/601ae71ee8ca5.image.jpg?crop=933%2C933%2C233%2C0&resize=933%2C933&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1171959" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
    </div>
</div></section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1171876" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1171876" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1171876');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1171877" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1171877" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1171877');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1171878" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1171878" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1171878');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1171933" class="tncms-block"><section id="block-1171933" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1171933 ">
        <div class="block-title-inner">
            <h3>
                
                Partner Sites
                
            </h3>
        </div>
    </div></div><div id="html-asset-1171933">
            <div class="html-content">
<p><a href="www.abqjournal.com/" target="_blank"><img src="https://www.abqjournal.com/wp-content/themes/jpc-wp-theme/assets/img/albuquerque-journalv2.png" alt="Journal" border="0"></a><br>
<br>
<a href="http://www.dchieftain.com/" target="_blank"><img src="http://news-bulletin.com//app/Chieftain.jpg" alt="Chieftain" border="0"></a><br>
<br>
<a href="http://www.rrobserver.com/" target="_blank"><img src="http://news-bulletin.com//app/RRObserver.jpg" alt="Rio Rancho Observer" border="0"></a></p>
</div>
        </div></section></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1171880" class="tncms-block hidden-xs"><div class="tnt-ads-container text-center  " >
        <div id="ad-1171880" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1171880');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1171870" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1171944" class="tncms-block"><section id="block-1171944" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1171944 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-community"  href="/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-special-sections"  href="/special/"  tabindex="0">
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-useful-links"  href="site/links.html"  tabindex="0">
                    <span class="nav-label">Useful Links</span>
                </a></li><li>
                <a class="nav-link   tnt-section-archives"  href="/search"  tabindex="0">
                    <span class="nav-label">Archives</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link   tnt-section-online-features"  href="/online_features"  tabindex="0">
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1171945" class="tncms-block"><section id="block-1171945" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1171945 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-staff-directory"  href="/site/staff.html"  tabindex="0">
                    <span class="nav-label">Staff Directory</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertise-with-us"  href="/site/advertise_with_us.html"  tabindex="0">
                    <span class="nav-label">Advertise With Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-a-legal-ad"  href="/site/forms/online_services/classified_ad/"  tabindex="0">
                    <span class="nav-label">Place a Legal Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=NEWS-BULLETIN&amp;publisher_url:news-bulletin.com#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscription-services"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link   tnt-section-print-subscriber-access-request"  href="/site/forms/subscription_services/print_subscriber_access_request/"  tabindex="0">
                    <span class="nav-label">Print Subscriber Access Request</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1171958" class="tncms-block padding-bottom"><section id="block-1171958" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/a2ac22f0-4062-11e5-9d86-4f9281c6270f.jpg?resize=200%2C93 200w, https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/content/tncms/custom/image/a2ac22f0-4062-11e5-9d86-4f9281c6270f.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-1171950" class="tncms-block"><section id="block-1171950" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1171950 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>Valencia County News-Bulletin</strong><br>
    221 S. Main St., Suite B<br>
    Belen, NM 87002
    <br>
    
        <strong>Phone:</strong> 505-864-4472<br>
        <strong>Email:</strong> <a href="mailto:vcnb@news-bulletin.com">vcnb@news-bulletin.com</a><br>
    
</address></section></div><div id="tncms-block-1171967" class="tncms-block padding-bottom"><div class="follow-links-1171967 default">
    
    <section id="block-1171967" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1171967 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="http://facebook.com/townnews/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/townnews/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/vcnewsbulletin/" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.news-bulletin.com",
  "sameAs" : ["http://facebook.com/townnews/","http://twitter.com/townnews/","https://www.instagram.com/vcnewsbulletin/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1171871" class="tncms-block">
        <div id="blox-ad-position-block-wallpaper-ad1" data-tnt-ads='{"vendor":"blox","type":"position","display":"wallpaper","region":"block-wallpaper-ad","slot":"1","fold":"","width":"2000","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/news-bulletin.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":false,"refresh":false}' class="blox-ad tnt-ads-container tnt-ads-wallpaper">
        
            <div class="hidden-md hidden-sm hidden-xs" id="wallpaper-left"></div>
            <div class="hidden-md hidden-sm hidden-xs" id="wallpaper-right"></div>
        
        </div></div><div id="tncms-block-1171951" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1171951"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">Valencia County News-Bulletin</a>, 1837 Camino del Llano Belen, NM</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>www.news-bulletin.com</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("e84959fa-740e-11eb-800e-5749e449e707")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.66c591eb93f177b0f59892f361c3b1b4.js"></script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'collection', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_1d054d74_7410_11eb_be47_13a1b89e4f1e_photo_modal = false;
                var gallery_changed_1d054d74_7410_11eb_be47_13a1b89e4f1e_photo_modal = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
	                        if (sInstance != null && sTarget != null){
	                            if (!sInstance.includes(sId)){
	                                oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
	                            }
	                            if (!sTarget.includes(sId)){
	                                oImage.setAttribute('data-target', '#photo-carousel-' + sId);
	                            }
	                        }
                        }
                     }
                $('#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .owl-stage-outer").height( $('#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_1d054d74_7410_11eb_be47_13a1b89e4f1e_photo_modal = $('#gallery-items-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal').data('owlCarousel');
                $('#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_1d054d74_7410_11eb_be47_13a1b89e4f1e_photo_modal.prev();
                });
                $('#carousel-1d054d74-7410-11eb-be47-13a1b89e4f1e-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_1d054d74_7410_11eb_be47_13a1b89e4f1e_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                            /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/news-bulletin.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.wallpaper.4566675f015f64f2a536e0f9f0611e13.js"></script></body>
</html>